Fuel filter??

This forum is for questions about modifications, or for if you are having a problem with your Neon and need answers.
User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Fuel filter??

Post by LH95sohc » Mon Jul 03, 2006 3:37 pm

When I drive my car when I hit about 2500 to 3500 Rpm my car lags like the a/c is on, but its not, I thought it was my plugs or maybe my coil but it wasnt. DO you think it could be my fuel filter? I dont understand why its doing it.
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

User avatar
Diablo0
Site Admin
Posts: 1133
Joined: Sat Jun 19, 2004 11:20 pm
Location: Greenville, SC - Simpsonville

Post by Diablo0 » Mon Jul 03, 2006 3:53 pm

We don't have fuel filters like most cars. The only thing we really have is a screan that covers the inlet of the fuel pump in the tank and thats it. How many miles on the car?
-Jason
Black '02 Neon R/T | White '02 Neon R/T (SRT-4 Engine Swap)
Click Sig Pic for more info
Image

Beer is living proof that God loves us and wants to see us happy.
- Benjamin Franklin

User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Post by LH95sohc » Mon Jul 03, 2006 10:48 pm

like 75000 i think
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Post by LH95sohc » Thu Jul 06, 2006 12:33 pm

ok so what else that happens is that once I end up at about 2500 rpm, and I stick the clutch in and give it a few quick revs, and it backfires every time I rev it almost like there is a lot of pressure build up and then when it gets past about 5 to 6 grand everything acts like its fine.
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

Neoncrazy101
Local Neon Owner
Posts: 203
Joined: Tue May 16, 2006 10:06 pm
Location: Dublin Ohio

Post by Neoncrazy101 » Thu Jul 06, 2006 1:10 pm

what year is your Neon? i'm changing the fuel filter in my Neon but mines a 1995.
Image

User avatar
evlneon
Local Neon Owner
Posts: 482
Joined: Fri Jun 25, 2004 11:23 pm
Location: columbus (dublin), ohio
Contact:

Post by evlneon » Thu Jul 06, 2006 6:13 pm

injectors might be clogged.... could try running some fuel system treatment through, but sometimes that will only make them clog up more.
PHIL | '03 MBP SUBY WRX | '98 FOREST GREEN NEON <- SOLD [img]http://diablo0.servehttp.com/neon ... .jpg[/img]
"Bryan! There's a message in my Alphabets! It says, 'OOOOOoooo.'" "Peter, those are Cheerios."

Metal_gear_jon
Local Neon Owner
Posts: 89
Joined: Sat Jul 09, 2005 10:53 am
Location: Sucksynati, Oh
Contact:

Post by Metal_gear_jon » Thu Jul 06, 2006 6:41 pm

leak in the intake?.... just my two cents....
'95 SOHC Sport ATX , slightly modded '95 SOHC Highline MTX , bought and sold. Shoot me , I needed the money.

User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Post by LH95sohc » Thu Jul 06, 2006 8:01 pm

I put fuel treatment in it, and that didnt do anything for it, my car is a 2001 btw, I just dont get it, it seems like every time I take it to the dealer, it gets messed up in some sort of way. Im sick of it, and now Im getting this knocking sound like a rod or somethin but it only happens half throttle. So my car is just a rolling thorn in my side... HELP!!!
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

User avatar
mynameiskiller
Local Neon Owner
Posts: 356
Joined: Wed Jun 23, 2004 1:57 pm
Location: the Cocoon

Post by mynameiskiller » Fri Jul 07, 2006 1:55 am

make sure your plugs are in tight... and check/torque them with the engine COLD. my 01 did that for a while and the #3 plug kept working its way loose because i always tightened it hot.
just remember, killer is sneaky... and, he hates you.

User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Post by LH95sohc » Fri Jul 07, 2006 11:06 am

I did do that, and it still didnt help, It seems to be getting worse, not to mention that that when I am gettin ready to stop, and I put the clutch in the car stays around 2500 rpm until my car comes to a complete stop... and on top of it all, my IAC sensor gives off a loud hum after I turn my car off.
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

User avatar
mynameiskiller
Local Neon Owner
Posts: 356
Joined: Wed Jun 23, 2004 1:57 pm
Location: the Cocoon

Post by mynameiskiller » Fri Jul 07, 2006 1:11 pm

are you getting any codes? the IAT or the TPS could be bad, maybe possibly the O2 sensor. all of those things contain the type of voodoo that would cause your drivability problems.
just remember, killer is sneaky... and, he hates you.

User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Post by LH95sohc » Fri Jul 07, 2006 5:44 pm

I havent check yet, I was gonna go buy an OBD II reader, but im short money, Ive heard that autozone will scan that shit for free, but I just havent had the free time to get out there. Idk all I know is that its getting really really frustrating, know what I mean?
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

User avatar
mynameiskiller
Local Neon Owner
Posts: 356
Joined: Wed Jun 23, 2004 1:57 pm
Location: the Cocoon

Post by mynameiskiller » Sat Jul 08, 2006 3:44 am

theres a way to get the codes by flipping the key on and off a few times... ill let you know if i find it.
just remember, killer is sneaky... and, he hates you.

User avatar
robert 'bob' paulson
Local Neon Owner
Posts: 44
Joined: Wed Mar 15, 2006 12:32 pm

Post by robert 'bob' paulson » Sat Jul 08, 2006 4:57 am

ON-BOARD DIAGNOSTICS

1. Cycle the ignition key ON-OFF-ON-OFF-ON within 5 seconds. To cycle the ignition key ON means to turn it only as far as it takes to get the radio to come on. It does not mean to turn the engine on.
2. Count the number of times the "check engine" lamp on the instrument panel flashes on and off. The number of flashes represents the code. There is a slight pause between the flashes representing the first and second digits of the code. Longer pauses separate individual codes. For example, flash-flash-flash [pause] flash-flash represents the code 32.
A code of "55" represents end of error codes. If this is all you get then no error codes are stored in the computer. This is the normal condition for a neon.

COD E Description of Trouble Code
11 Timing belt skipped 1 tooth or more from initial learned value, Intermittent loss of either camshaft or crankshaft position sensor, No crank reference signal detected during engine cranking
12 Direct battery input to PCM was disconnected within the last 50 key-on cycles
13 No change in MAP from start to run
14 MAP sensor voltage too low
15 No vehicle speed sensor signal
17 Closed loop temp not reached or engine cold too long
21 02s sensor problem (oxygen sensor), upstream or down stream
22 Engine coolant temp sensor out of range
23 Intake air temp sensor out of range
24 Throttle Position sensor out of range
25 Idle air control motor circuits, target idle not reached (+/- 200),vacuum leak found
27 Injector control circuit
31 Evap purge flow monitor failure or evap solenoid circuit
32 EGR system failure
33 A/C clutch relay circuit
34 Speed control Solenoid circuits
35 Rad Fan control relay circuit
37 Torque converter clutch solenoid CKT or park/neutral switch failure
41 Generator field not switching properly
42 Fuel pump relay control ckt, Auto shutdown relay control ckt, No ASD relay output voltage at PCM, Fuel level sending unit volts out of range, Fuel level unit No change over miles
43 Multiple/ single cylinder misfire
44 Battery temp sensor volts out of range
46 Charging system voltage too low
51 Fuel system lean
52 Fuel system rich
53 Internal control failure
54 No Cam signal at PCM
55 End of error messages (If you get this only, no errors were found)
62 PCM failure SRI mile not stored
63 PCM Failure EEPROM write denied
64 Catalytic Converter Efficiency Failure
65 Power steering switch failure


There ya go.

User avatar
LH95sohc
Local Neon Owner
Posts: 411
Joined: Wed Dec 01, 2004 1:43 pm
Location: Reynoldsburg Ohio [columbus]
Contact:

Post by LH95sohc » Sat Jul 08, 2006 3:39 pm

I thought that was only for 95-99 with the whole key turn thing. I guess I'll try it. I talked to a couple of mechanics they said it could be my O2 Sensor or my TPS sensor, so Idk.
-SEAN

SRT-4 is king of the Street
Cbussilver01es on 2GN!!!!

Image

Post Reply